Phone System
Incident Report for Immedicare
Resolved
This incident has been resolved.
Posted Sep 28, 2020 - 11:05 BST
Update
We are continuing to monitor for any further issues.
Posted Sep 28, 2020 - 10:40 BST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Sep 28, 2020 - 10:40 BST
Identified
The issue has now been resolved but we continue to monitor

We are currently experiencing an issue with our phone system. Whilst we resolve this issue please call 01925 937186.
Posted Sep 28, 2020 - 10:31 BST
This incident affected: Technical Support Desk.