Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted May 21, 2024 - 08:00 BST
Scheduled
We will be carrying out essential maintenance during this time and the Immedicare service will be unavailable during this time. If any of your residents become unwell and it is safe to wait till after 9 am to contact clinical support please call us after this time. However, if urgent support is require please call 111/999.
We apologise for any inconvenience.
Best Wishes
Immedicare Team
Posted May 16, 2024 - 11:20 BST
This scheduled maintenance affected: Immedicare Hub.