Technical Support Contact
Incident Report for Immedicare
Resolved
The incident has now been resolved and the system is back in full working order, any issues then please contact support via the laptop or on the phone 0330 088 3312.

We apologize for any inconvenience caused.

Best Reagrds

Immedicare Support
Posted Jan 07, 2025 - 14:18 GMT
Investigating
Dear Immedicare user,

We are currently experiencing an issue contacting Technical Support when calling us directly from Jabber on your Immedicare laptop.

If you are experiencing any technical issues we are still available for you. Please call us on 0330 088 3312.

If you need to contact the Nurses please continue as normal as this is not affected.

Best regards,

Immedicare Support.
Posted Jan 07, 2025 - 12:00 GMT
This incident affected: Technical Support Desk.