Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Aug 20, 2024 - 06:30 BST
Scheduled
We are carrying out some routine maintenance on the system on 20/08/2024 from 06:30am until 08:00am during this time and the Immedicare service may be unavailable during this time. If any of your residents become unwell and it is safe to wait till after 08:00am to contact clinical support please call us after this time. However, if urgent support is required, please call 111/999.
We apologise for any inconvenience.
Best Wishes
Immedicare Team
Posted Aug 15, 2024 - 14:04 BST
This scheduled maintenance affected: Immedicare Hub.