Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 17, 2026 - 08:00 BST
Scheduled
Dear care home staff and management,
On Thursday 17th September between 08:00 – 09:00 Immedicare will be carrying out planned maintenance of the platform. During this time the there may be some interruption to the service but we will keep this to a minimum.
Posted Sep 17, 2026 - 07:25 BST
This scheduled maintenance affected: Immedicare Hub.