Technical Outage

Incident Report for Immedicare

Resolved

Dear Immedicare Customer,

We are pleased to advise the issue has now been resolved and apologise for any inconvenience caused the system is now back in a fully working state and if you have any issues please contact the support team from your device or by calling on 03300883312.

Best regards,

Immedicare Customer Support
Posted Dec 22, 2024 - 13:03 GMT

Investigating

Dear Immedicare Customer,

We are currently experiencing a Technical Outage affecting calls into the Nursing team and Technical Support team. At this moment in time the service is unavailable and we are doing all we can to return to normal service as soon as possible.

During this time if any of your residents become unwell and urgent support is required please call 111/999.

Apologies for the inconvenience this may cause, and thank you for your patience while we resolve this.

Best regards,

Immedicare Customer Support
Posted Dec 22, 2024 - 11:19 GMT
This incident affected: Immedicare Hub and Technical Support Desk.